Windscreen wipers not working !

 
Post new topic   Reply to topic    The Land Rover Club Forum Index // Introduce yourself
View previous topic :: View next topic  
Author Message
Robert mcgowran
Newcomer


Joined: 26 Dec 2017
Posts: 5
Location: Birmingham

PostPosted: Thu Dec 28, 2017 7:02 pm    Post subject: Windscreen wipers not working ! Reply with quote
Hi All,
Can any body help me with this problem ! Accidentally activated the wipers while deicing,they moved slightly then nothing ! Not mechanical or electrical minded yet so what and where do I check ? I have took it to local garages but no one will have a look until the 2nd January! So I've had to book it in for then but maybe with some advice I can sort it meself ! Cheers all .👍
Back to top
View user's profile Send private message Visit poster's website
Alan Drover
Moderator


Joined: 31 Oct 2013
Posts: 2510
Location: North West Hampshire

PostPosted: Thu Dec 28, 2017 7:57 pm    Post subject: Reply with quote
Evening Robert.
Once the wiper motor is turned on then immediately off, the parking switch remains active until the wipers have returned to the park position. If they can't because as has happened the blades are frozen to the screen then there are 2 possibilities. First the fuse has blown. The direction indicators are on the same fuse so if they don't work that's your problem. If they do then the motor is faulty. The fuses are under the plastic cover under the steering column inside the vehicle.
I'm assuming you have a Series 3. If it's a 90/110 let me know and I'll look at the relevant wiring diagram
_________________
Alan Drover.
1975 SWB hardtop with a 2.5 petrol engine, overdrive, front disc brakes, parabolic springs, hand throttle, Defender doors and Wolf wheels.
Also a 1977 Stage 2 MGB GT.
Back to top
View user's profile Send private message
Alan Drover
Moderator


Joined: 31 Oct 2013
Posts: 2510
Location: North West Hampshire

PostPosted: Thu Dec 28, 2017 8:51 pm    Post subject: Reply with quote
Rob.
Didn't link you with the new member from Solihull thread so I now know you have a 2003 Defender. I can't help because I don't have a wiring diagram for the later Defender. Still worth checking the fuses though.
_________________
Alan Drover.
1975 SWB hardtop with a 2.5 petrol engine, overdrive, front disc brakes, parabolic springs, hand throttle, Defender doors and Wolf wheels.
Also a 1977 Stage 2 MGB GT.
Back to top
View user's profile Send private message
Robert mcgowran
Newcomer


Joined: 26 Dec 2017
Posts: 5
Location: Birmingham

PostPosted: Thu Dec 28, 2017 9:01 pm    Post subject: Windscreen wipers not working Reply with quote
Thanks for your reply Alan! Yea it's a defender 90 td5xs and the indicators are still working so I will check the fuses in the morning and go from there ! I'd prefer to have a clue when I take it into a garage !
So thanks very much for your advice !
Much appreciated in these early days of owning a landy !
Back to top
View user's profile Send private message Visit poster's website
Alan Drover
Moderator


Joined: 31 Oct 2013
Posts: 2510
Location: North West Hampshire

PostPosted: Thu Dec 28, 2017 10:39 pm    Post subject: Reply with quote
Rob.
Your Defender will have far more fuses than the 4 of the Series 3 so I would reckon that most items have their own fuse so it's a matter of finding if one has blown. Make sure you replace it with one of identical rating. If that one blows immediately then it's likely there's a fault in the motor.
Keep us informed please.
_________________
Alan Drover.
1975 SWB hardtop with a 2.5 petrol engine, overdrive, front disc brakes, parabolic springs, hand throttle, Defender doors and Wolf wheels.
Also a 1977 Stage 2 MGB GT.
Back to top
View user's profile Send private message
Robert mcgowran
Newcomer


Joined: 26 Dec 2017
Posts: 5
Location: Birmingham

PostPosted: Fri Dec 29, 2017 7:03 pm    Post subject: Windscreen wipers not working Reply with quote
Hi Alan,
Yea I eventually located the fuse number 9 in the fuse box and replaced it ! And the wipers are working again so job done hopefully no more probs ! So thanks again Alan for your guidance and advice, much appreciated ! Till the next time !! Cheers !
Back to top
View user's profile Send private message Visit poster's website
Alan Drover
Moderator


Joined: 31 Oct 2013
Posts: 2510
Location: North West Hampshire

PostPosted: Fri Dec 29, 2017 8:01 pm    Post subject: Reply with quote
Rob.
That's good news. Pleased I was of some help.
Have a good New Year.
_________________
Alan Drover.
1975 SWB hardtop with a 2.5 petrol engine, overdrive, front disc brakes, parabolic springs, hand throttle, Defender doors and Wolf wheels.
Also a 1977 Stage 2 MGB GT.
Back to top
View user's profile Send private message
Post new topic   Reply to topic    The Land Rover Club Forum Index // Introduce yourself All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum